Password update field missing and 401 unauthorized when trying to change password with API

Jump to solution
Community Member

Using our organizations Admin account, I have tried opening student accounts to change their password but in the Update Login menu, there are no password or confirm password options available.

I tried to do a password update using the API but I am getting a 401 Unauthorized error but every other API call I have tried works. I created a new access token but that did not work either. 

I tried to use the live API at https://{institution} and used the old as well as the new access tokens, went to the Login section and under PUT, I entered in our organization account_id, added the id for the student login_id (I also tried the student canvas_user_id) and added a new password in the login[password] field and I get a 401 Unauthorized error.

I verified in the permissions that the Account Admin role has access to 'Users - list view', 'Users - manage login details' and all over Users permissions are set as well.

Is there something else I could be missing?

1 Solution

Hi Bret, 

This sounds like a Canvas support question, as it will most likely involve them double checking the settings and seeing if you need to reach out to your CSM. It is possible there is a backend setting that is restricting your access to edit passwords, as denoted in this guide. Based on your statements, it's highly likely this is the case. 

Additionally, please note that when you make changes on the permissions page, it does take approximately 30 minutes for them to be synced. Reaching out to Canvas support and explaining what you're seeing on your end is the best practice for a case like this. 

View solution in original post