Problem with new quiz imported from Commons

Jump to solution
Community Member


The last couple years, I built up many banks of test questions and made tests by having questions pull from banks. This year, I changed school districts. In an effort to retain all of my work, I uploaded my old course into the Commons and downloaded it into my new course. When I try to open my created tests, I get this error message: "Couldn't find valid settings for this link." I thought maybe it was because the questions are being pulled from a bank, and the banks don't import from Commons. So I went back to my old course, took all the questions out of the banks, made a quiz with all my questions (that doesn't pull from any banks), re-imported the old course into Commons, and re-imported the course into my new course. I got the same error message. Then I realized that the link in the external tool for the quiz goes to my old school district, so I tried changing the link to my new school district. That got the quiz page to open up, but there were no questions loaded onto it.

Is there any fix for this? I would be so grateful if someone could tell me how I can see my old test questions. Am I missing a step?

Labels (2)
1 Solution
Community Team
Community Team

@MatthewGreen729 Unfortunately, sharing New Quizzes between different instances of Canvas is not currently supported.  If you have a version of the quiz built as a Classic Quiz in your previous district, you can transfer it to your new district by running a Quiz (or course) export and then importing that into your new courses at the new district (or using Commons if both districts allow this). 

The feature for exporting New Quizzes between Canvas instances is on the roadmap for New Quizzes, but stated as "Possible Later" without any specifics in regards to date. Quizzes Transition Roadmap 

View solution in original post