[Admin Tools] Make all LTI placement types obey "open in new tab" rules set by the windowTarget blank property

Problem statement:

When adding LTI tools, we specify in the XML that the tool should open in a new tab/page/window by setting the property: lticm:property name="windowTarget" _blank This works properly for some placement types such as course_navigation placement. However, seemingly arbitrarily, it does not work for other placement types such as user_navigation or course_settings_sub_navigation placement. Canvas defies the property, does not set the target="_blank" link attribute, and does not open the link target in a new page/tab/window. This idea is to fix this issue and have Canvas obey the open-in-new-tab attribute for ALL LTI placements/placement types.

Proposed solution:

The proposed solution is to have Canvas obey the open-in-new-tab attribute for ALL LTI placements/placement types for all LTI tools. If we specify the following attribute, please follow the intention and open the tool target in a new window regardless of which placement the tool link has. lticm:property name="windowTarget" _blank Thank you for considering this fix.

User role(s):

admin,designer

2 Comments
c_carrillo1
Community Participant

There is a duplicate of this idea.  This is the correct one, please retain this one. Thank you.

AlexisNast
Instructure
Instructure
Status changed to: Added to Theme

Thanks for the suggestion! This has been added to the "Improve ability for tool developers to use same functionality between Canvas and other LTI Platforms" theme for further consideration.