Canvas Parent Issue, Not Loading

Jump to solution
Community Member

I downloaded Canvas Parent for the first time on my current phone and it is not loading. I get a white page with the blue canvas logo that spins, and never get to enter Canvas Parent. I tried troubleshooting this with the school district’s IT department and also with Apple to no avail. Apple determined it is a Canvas Parent app issue, the school’s IT person told me it’s my phone’s issue. I cannot get anywhere with this.


To be clear, I have offloaded the app, deleted the app, refreshed my phone, updated my phone, reset network settings, checked for Canvas Parent updates, and other details that Apple had me attempt. Nothing has worked.  

I am attaching the screenshot of the app. This is the only thing the app does when I open it.

Labels (2)
1 Solution
Community Novice

Thanks, KristinL. This does work, but the instructions need updating. After downloading the app and trying to open it, I only saw the spinning blue Canvas parent logo. Directions indicate scanning the code after seeing a welcome screen and choosing QR code login. That does not appear. I used my phone camera to scan the QR code from my online instance of Canvas. My iPhone gave me the option to open in Canvas Parent, which I clicked. It went right to my son's account. Thanks!

View solution in original post