cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dp
Community Participant

Must have at least one redirect_uri defined when adding a LTI key

When adding an LTI Key in the Developer keys section, I am receiving an error "Must have at least one redirect_uri defined.". What could be the reason for receiving this error?

 

Developer-Keys.png

 

Public JWK:

{
"title":"(SATool)",
"description":"1.3 Test Tool used for documentation purposes.",
"privacy_level":"public",
"oidc_initiation_url":"https://127.0.0.1/home/oidcLogin",
"target_link_uri":"https://127.0.0.1/home/index",
"scopes":[],
"extensions":[
{
"domain":"localhost:44399",
"tool_id":"course-nav",
"platform":"canvaslms.myftp.org",
"settings":{
"text":"SATool",
"placements":[
{
"text":"User Navigation Placement",
"enabled":true,
"placement":"course_navigation",
"message_type":"LtiResourceLinkRequest",
"target_link_uri":"https://127.0.0.1/home/index"
}
]
}
}
],
"public_jwk":"(SATool)",
"custom_fields":{
"bar":"$Canvas.user.sisid"
}
}

 

Tags (1)
0 Kudos
1 Reply
matthew_buckett
Community Contributor

In your screenshot the you have the whole tool configuration in the Public JWK field, but it should be something like:

{
"kty" : "RSA",
"e" : "AQAB",
"use" : "sig",
"kid" : "lti-jwt-id",
"alg" : "RS256",
"n" : "gPOu7BpVd06XplDNZUVKXd-59CLiQJM6ELzT5erke1XKzz7lC-3-3Z0DVh1arw_JNC0D9VqIRtRwglo-7GpX_yU0CggvsQ6Vq2_n0lqay0PTLgIVQdvXhABxlYHe56SHyP4_wmQubvYV92Z7s7L8Uqq87EkZ0IhduJCg18EdesM6KuQAlzb_s_eOTUibqXRYZdTR1hmxIEYvn9EjupqhRtGqqIaVEvXOJxzcm40IKnuAy9zBUyWb4nF6eaz3bGxHb-_k1Rc4ZAX5nI6TWZIiNB8hYENyuwLXvSYZ-gJEUuA4ZAdsCrEhIkZiLtrWAID0BxGZorPWhqqKwWVddv5Z5Q"
}

If you aren't using any LTI advantage services (eg Names and Roles Provisioning Service) then you don't need to have a value Public JWK, as the tool launch doesn't use this part of the configuration.