Tera Lisicky

Is there a workaround to embedding Amara and Overstream captioned videos?

Discussion created by Tera Lisicky on May 28, 2015
Latest reply on Jun 9, 2015 by chofer@morainepark.edu

Hello Fellow Pandas,

 

I am having trouble with embedding Amara and Overstream videos in both Canvas and Google Sites.

 

Amara has JavaScript in the embed code.

 

Overstream has Shockwave in the embed code.

 

I am hoping for an easy solution (or app) to help all faculty easily embed 3rd party captioned videos in their courses.

 

I posted some notes here:

 

I am having trouble with embedding Amara and Overstream videos into my Canvas shell.

 

Here is the link to an example Amara video:

Intro to Psychology - Crash Course Psychology #1 with subtitles | Amara

 

They say to embed it by pasting the following items:

 

Paste this in your document somewhere (closest to the closing body tag is preferable):

<script type="text/javascript" src='http://amara.org/embedder-iframe'> </script> 

Paste this inside your HTML body, where you want to include the widget, with the width and height of your choosing:

<div class="amara-embed" data-height="370px" data-width="620px" data-url="http://www.youtube.com/watch?v=vo4pMVb0R6M"> </div> 

Here is an example of an Overstream video:

http://www.overstream.net/view.php?oid=ruuxifrjazef&query=ted+talk&s=search&pt=1&pn=1&pc=1&pu=1&pl=-1&related=search&skip=0

I have been playing with this for hours and can't get the embed codes for Overstream and Amara to work in Canvas and also in Google Sites. I was trying a workaround to embed it in Google Sites to then use an External URL for captioned videos found in Amara and Overstream with no luck. Overstream's embed code uses Shockwave (which is not supported on Macs with 10.10.3 to my knowledge currently) and Amara that uses JavaScript.

 

Any ideas? I have been recommending that faculty use Amara and Overstream for videos they find that are not captioned to caption the videos but this is a roadblock. Google sites said that they stripped my embed code. I noticed that both embed codes do not contain https so I added an s to the http to see if that would help but no luck.

 

Thank you for your help in advance. :-)

 

Cheers!

Tera

Outcomes