Assignment not showing up in "add to module" list?

Jump to solution
Community Novice

I am trying to add an assignment from my assignment page into a module. However, it won't show up when I click the plus icon and select "assignments" - it is just not in the list. I logged out and back in, unpublished and republished the assignment, refreshed the page, all with no luck. Any advice? 

3 Solutions
Community Participant

Hey  @opetersen ‌ - I'm not sure how or why but I did seem to shake it loose somehow. First, I noticed that the module into which I wanted to add an assignment included a prerequisite. I'm not sure if that makes a difference but it seemed relevant. I unpublished the module and then republished it. And when I did that, I was prompted to Re-lock the module since I touched the progression requirements. I accepted.

The assignments I wanted to add were new but I had changed their names since creating them. I was now able to see the new assignments with the old name and add them to the module. I then removed them and when I tried to add them again, the new name popped up.

You are probably right about the time fixing the problem - a lot of fiddling about. :smileyconfused:


View solution in original post

Community Explorer

same issue. I've had to find the assignment in the assignment page, copy to, select the SAME course I built it in and select the module I want it to go to. It's a work around but NOT what I should have to do -- total time suck. I've tried logging in & out, waiting up to 30 min, but honestly, who can wait 30 minute neverless 24 hours as someone suggested? 

View solution in original post

Community Participant

What you describe can be a problem, but in general this is not the problem everyone else is having. I have Canvas open in a single tab. I can do a hard-reload, clear cookies, clear the cache, etc. and there be no effect on what shows up.  Canvas has told my university the problem is their servers are busy processing other work. There's nothing you can do to make their servers speed up.

View solution in original post