Canvas Collaborations not generating with Google Assignments LTI 1.3

Community Explorer

I'm trying to create collaborations with Google Assignments LTI 1.3. When I go through the process, the tool creates the document in my Google account, but Canvas doesn't seem to want to create the collaboration on its end. Nothing shows up in Current Collaborations.

It works if I use Google Apps LTI (so thank goodness that's not being sunsetted anymore lol) -- those appear in my Google account, open in a new tab, and show under Current Collaborations. But LTI 1.3 goes nowhere other than creating a file in my Google account and making it available to the school at large. 

Here's a video showing the error (and as a fun aside, Canvas gaslighting me into thinking I have a feature turned on lol).

Here are some things I've done:

  • I enabled and disabled the External Collaborations Course feature in Feature Options. No dice on either setting.
  • I checked Google Admin, and we do have Assignments turned on for everyone. 
  • I updated Chrome. 
  • I looked at Collaboration from my demo student (not the test student) account. Nothing.
  • I tried on Edge. Nothing.
  • I haven't tried it from two different devices or networks, but if it's my network I'm really in trouble. I'm supposed to be demoing this for faculty tomorrow. 😬

I've contacted Canvas Support, and the person I'm working with says this is a problem they've been hearing about lately but they said it was "outside of the scope of [their] support". They told me to reach out to Google LTI 1.3 support, but couldn't find the contact information or process when I asked. I looked in the Google community threads and found this post from January, but there's only one response and it isn't a solution. I'm going to post this there and in the 'Report Issue/Send feedback to Google' area in Canvas (which i just found), but I'm not very hopeful. 

SO! Does anyone have any ideas? 😅