Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sszabo
Community Member

Equation Editor

Jump to solution

What happened to this? It became absolutely unusable. Previously when I typed the latex I saw it and could check the correctness of it, and to modify if it was necessary.

Labels (1)
20 Replies

question is:  is it possible to have the "directly edit latex" always in the "on" position, rather than re-enabling it each time?

ezaurova
Community Member

James, that bug/feature, whatever you want to call it, of being able to type in LaTeX without enabling direct entry of LaTeX and having that typeset if you click inside the editor window but outside of the input box can be a decent workaround for now, so thanks for sharing that observation.

But while you experience a 6 second or so delay, others, like myself and the two other commenters, are not getting it to render at all, even after waiting minutes.  I see the \(\alpha \) below forever :(.

SteveTanner
New Member

I'm having problems with some of the changes as well.

The chief complaint from my students is that they can no longer move the editor window so that if they are creating a post, they can see the previous portions of their post while using the editor.

But there also seems to be a problem with the basic integral symbol.  I haven't found a way to produce an indefinite integral without going into "Directly Edit LaTeX" mode.  If you produce an integral symbol in basic mode, the editor seems to assume that you will be filling in limits of integration.  If you leave them blank (or try to erase them or put in white space) the editor can produce something like:

\int_{\placeholder{⬚}}^{\placeholder{⬚}}xdx

or like

\int_^

neither of which will actually produce a symbolic result.

 

Since this update I've also had two students create posts which disappeared once they hit "Post Reply".  I'm not sure if it is a related problem, but I have never had it happen prior to the recent update.

James
Community Champion

Elena ( @ezaurova )

If your institution has a support package with Canvas, be sure to submit a help ticket. I'm not sure that a bunch of us complaining in the Community makes it to the people that need to fix it. For those without institutional support packages, the Community is the place to get help, but I saw @KristinL  telling someone to break it into multiple complaints rather than one complaint with three (they missed some) issues.

ezaurova
Community Member

@James For sure.  I submitted the ticket yesterday when I realized from @bowmanr's screenshots that what I was seeing wasn't the intended behavior.

ezaurova
Community Member

By the way, this hasn't been "solved".  The issue is that the rendering seems to work fine when working with the equation editor in an Assignment, but doesn't work when using it in a Quiz.  This might be the reason some of us are seeing it render fine and others are not.  I've submitted the bug report already and they're investigating the issue.  But rather than marking this as "solved", it would be great if others who are experiencing this bug also reported it.

bowmanr
Community Champion

@ezaurova -

Good catch on it not operating the same in different areas.  I cannot remember what I tested it in - probably an assignment.  I imagine that wherever the RCE can be used should be tested by Instructure to ensure that it is working properly

James
Community Champion

@ezaurova ,

While I agree that the issue isn't resolved, solved doesn't mean the same that it did in the old community software. Solved now seems to mean that it answered someone's question, not necessarily that the original question was answered or that the person marking the answer as a solution is the same as the person who originally posted the question. They have made it so that anyone can mark a question as solved.

From the Community FAQ: When community members answer one of your questions, you can choose the answer or answers you think are the most useful, helpful, or accurate and mark them as a solution. If you have two answers that give part of the solution, you can accept both.

In other words, I could mark your response about it not being solved as a solution.

ezaurova
Community Member

Thanks @James.  Fortunately, it seems they did just fix the issue.  I got an email a couple of hours ago letting me know they deployed a fix.  I just checked, and it's now rendering as expected in the editor in a Quiz.  @sszabo You should check that it's also working as expected on your end.

sszabo
Community Member

@ezaurova  Yes, it works well. I like this community, because if there is a problem they solve it (or at least try to find some solution). ❤️