Help with Edit Assignment Dates

Jump to solution
Community Participant

Once upon, in the Edit Assignment Dates feature, all the assignment titles were displayed so I could use command-F or a similar search feature to find a specific assignment and quickly change the title. Then, the feature was changed and it no longer has searchable titles. Now, you can hover the mouse over a title but that is not helpful in a course with 100+ assignments. Help! How do I get back the ability to quickly find my needle in a haystack assignment?

In gratitude, Jesse

Labels (2)
1 Solution
Community Champion


Here are some questions to think about that might lead us towards a solution.

Is this problem specific to Firefox? Does it work with other browsers? Does it work with private mode (Shift+Cmd+P)? Does it allow you to search for items that are not in the list? Does it work on other browser pages?

My mac is too old to load Sonoma (I still have Monterey), but I just tried it with an updated Firefox 124. I wasn't able to get the edit assignment dates to load properly, but it may have been because I just turned on my mac after having it off for a month and it was running updates. It could also be related to the JavaScript error I'm getting from React that keeps it from formatting properly (but I get the same error on Chrome with Windows 10). It could be something with my Mac since it didn't format properly for Firefox, Chrome, or Safari. Or it could be something wrong with Canvas.

Despite all that, I have 191 assignments in my course and I did a Cmd+F and it found items both on and off the screen. If it was formatted properly, that might not have worked, but it doesn't look like I can test that right now.

The reason for trying private mode is that it disables most extensions and you might have one of those that is causing problems with the Cmd+F working properly on the page.

I'm not sure about Macs, but I've ran into the issue of some Windows software taking over functionality. Some gaming software does this and I've seen webcam software do it as well.

There is a way to find things even when Cmd+F doesn't work, but I would try to figure out if there's something else preventing it first.

You can open the developer tools (F12) in Firefox, go to the Inspector tab and there is a "Search HTML" box directly above it. Type in the name of your assignment there and hit enter to search. Then, if you mouse over the highlighted HTML it will show the content (if it's on the page). If it's not on the page, you may need to right-click (two-finger tap) and say "Scroll Into View". I had trouble with this working with the last assignment in the list, but I think it might have been selecting the wrong text. It worked fine with the next-to-last-item.

View solution in original post