cancel
Showing results for 
Search instead for 
Did you mean: 
david_agruss
Community Member

How can I make internal hyperlinks in a PDF document work when the PDF is viewed in a Canvas window?

I created a long Word document for my students, and, for ease of navigation, I created internal hyperlinks (which are called "Bookmarks" in Word) so that my students can easily and quickly navigate to different parts of the document by clicking the hyperlinks. I saved the Word document as a PDF, verified that the hyperlinks still work in the PDF (they do), uploaded the PDF to "Files" on Canvas, and then created a link to the document in a module on Canvas. When I click on the link to the document in Canvas, Canvas opens the PDF in a Canvas window. If I then click on the hyperlinks while viewing the PDF in the Canvas window, the hyperlinks don't work. That is, I click on the hyperlinks, and nothing happens. If I download the PDF by clicking "Download" in the Canvas window and then open the document on my desktop, however, the hyperlinks work: I click on the hyperlinks, and they take me to the correct spot in the PDF. How can I make these hyperlinks work while viewing the PDF in the Canvas window?

Tags (1)
3 Replies
stuart_ryan
Community Coach
Community Coach

Hi David,

I wonder if this is more to do with the in-browser PDF viewer, rather than Canvas directly.

As a test, could you possibly try to open the downloaded PDF within your browser (either by dragging and dropping the PDF onto the browser icon, or File --> Open --> navigate to PDF).


I would like to see if the in-browser view standalone works or if it also experiences the same issue! Please let me know how you get on.

Stuart

trina_larson
Community Member

Hi David and Stuart,

I just ran into the same problem and followed your diagnostic suggestion, Stuart. When I opened the internally hyperlinked doc in both Chrome and Safari browsers, the document's hyperlinks worked fine.

In Canvas, the same hyperlinked text does become highlighted when hovering above it (suggesting a link is active), but when clicked, the page doesn't advance/the link doesn't work.

These internal links are so helpful for longer documents, as David points out.

Any suggestions?

Thank you!

Trina

clmckoy
Community Participant

I have the exact same problem as Dave and Trina indicated. I note that there hasn't been a response since Trina's post. Is there a work around or a resolution to this issue?