cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kschmid
New Member

How do you get module assignments into the assignment section?

Jump to solution

If you created an assignment in Modules instead of in Assignments, how can you get it added to the Assignment list so it appears in the grade book?  There seems to be no copy function, and the move command only seems to move things within the modules. It is already published and appears in Student View:  too late to do it over, and who wants to waste another five hours even if it weren't too late?  Filling in 60 different boxes and then fixing all the mistakes is tedious enough the first time.

2 Solutions
Chris_Hofer
Community Coach
Community Coach

Hello  @kschmid  Welcome to the Canvas Community.  Thank you for posting your question.  I'm not sure I totally understand what you are asking, however.  The "Modules" page is merely the place where you can organize all your course content just the way you want it...into modules....putting your pages, discussion topics, quizzes, assignments, etc. in the order that you want into each of your modules (units, chapters, lesson plans, etc.).  So, when you say that you added an assignment to your "Modules" page...that same assignment will automatically be added to your "Assignments" page, too.  If you publish the assignment via your "Modules" page, it will be be published on the "Assignments" page, too...because it's the same item.  You do not need to "copy" an assignment from the "Modules" page back to your "Assignments" page...because it should already be there.

 

 

There may be some settings in the assignment itself which would make it appear (or not appear) in the Gradebook...but for the most part, the assignment should be there.

I hope this helps, Katherine.  Please let Community members know if you have any questions about this information.

View solution in original post

atazzam
New Member

I have noticed this issue a few times in the spring 21 semester and not found any answers online.

 

The following is the order of operations I am using.

  1. A template course was created manually with content (Pages, Files, assignments, modules, etc).
  2. Actual live courses for students are provided by our university.
  3. Modules are moved from the template course to actual course with "Copy to" feature.
  4. In the actual courses after copying, some have the module with content, but the assignments are not displayed in the assignment tab.

I am copying these items to 10 courses and it seems to happen on 3 or 4 out of 10 sections each time.

  1. The gradebook does not show the assignments for these 3 or 4.
  2. The Course Calendar oddly does.
  3. If I edit one of these "missing" assignment from the modules page and add it to a new assignment group, then the missing assignments show up in the assignments tab and the gradebook under the new assignment group. 

 

One thing I noticed above was that the "copy to" feature (annoyingly) puts assignments in the Imported Assignments group (which it usually creates for you).

For these missing assignments, they are sent to a group called "Assignments".

View solution in original post

0 Kudos
8 Replies
Chris_Hofer
Community Coach
Community Coach

Hello  @kschmid  Welcome to the Canvas Community.  Thank you for posting your question.  I'm not sure I totally understand what you are asking, however.  The "Modules" page is merely the place where you can organize all your course content just the way you want it...into modules....putting your pages, discussion topics, quizzes, assignments, etc. in the order that you want into each of your modules (units, chapters, lesson plans, etc.).  So, when you say that you added an assignment to your "Modules" page...that same assignment will automatically be added to your "Assignments" page, too.  If you publish the assignment via your "Modules" page, it will be be published on the "Assignments" page, too...because it's the same item.  You do not need to "copy" an assignment from the "Modules" page back to your "Assignments" page...because it should already be there.

 

 

There may be some settings in the assignment itself which would make it appear (or not appear) in the Gradebook...but for the most part, the assignment should be there.

I hope this helps, Katherine.  Please let Community members know if you have any questions about this information.

Thank you! You were right that where I created the assignment wasn’t the problem at all.

Changing a setting inside the assignment and discovering a new gradebook column lurking off-screen, to the right of the subtotal columns, solved both the assignment page and gradebook confusion.

I'm having the same problem.  When imported course content, Assignments do not show up under the "Assignments" tab.   The assignments show up in Modules tab only.   I tried readjusting the Gradebook as the previous indicated, but had no luck.

Would appreciate any suggestions on how to get assignments into the "Assignments" tab would  be appreciated.

Hi  @denise_childs  Welcome to the Canvas Community!

I just tested this in my Canvas Instance, and any assignment created in Modules is included in the Assignments Index page - even unpublished ones with absolutely no settings set, and even ones set to not be calculated into the final grade. I tested this three times without fail.

It is either a browser issue, or a bug in your account that needs to be reported to Canvas Support. This guide will help you submit a support ticket https://community.canvaslms.com/docs/DOC-12877-4152719652?sr=search&searchId=ba7a0701-8206-4e85-a8ab... 

Kelley

0 Kudos
atazzam
New Member

I have noticed this issue a few times in the spring 21 semester and not found any answers online.

 

The following is the order of operations I am using.

  1. A template course was created manually with content (Pages, Files, assignments, modules, etc).
  2. Actual live courses for students are provided by our university.
  3. Modules are moved from the template course to actual course with "Copy to" feature.
  4. In the actual courses after copying, some have the module with content, but the assignments are not displayed in the assignment tab.

I am copying these items to 10 courses and it seems to happen on 3 or 4 out of 10 sections each time.

  1. The gradebook does not show the assignments for these 3 or 4.
  2. The Course Calendar oddly does.
  3. If I edit one of these "missing" assignment from the modules page and add it to a new assignment group, then the missing assignments show up in the assignments tab and the gradebook under the new assignment group. 

 

One thing I noticed above was that the "copy to" feature (annoyingly) puts assignments in the Imported Assignments group (which it usually creates for you).

For these missing assignments, they are sent to a group called "Assignments".

0 Kudos

Hello there, @atazzam ...

Thanks for the detail on how you are using the "Copy to" function within Modules of your course to copy content from one course to another.  As an alternative way to do things...have you tried using the Course Import Tool instead to copy only specific content from one course to another?  This would be similar to the "Copy to" function....and you'd just be selecting the module you want to copy/import from one course to another.  How do I select specific content as part of a course import?

Let Community members know if you have any questions about this...thanks!  Take care, stay safe, and be well.

0 Kudos
atazzam
New Member

The "Copy to" feature allows one person to broadcast(?) content to many sections from one location, i.e. from a template course to multiple sections of that course which are running.

The Import tool has to be used from each section individually. Also, there are a number of options and settings to select the content from your template before it is imported to each section.

atazzam
New Member

The same "missing assignments under assignment tab" issue occurs when copying quizzes from a template to courses.

For the same 4 / 11 sections, the quizzes copied to the course appear under the Quizzes tab, but do not appear under the assignments tab.

 

The following is the order of operations that was used.

  1. A template course was created manually with content (Pages, Files, assignments, modules, etc).
  2. Actual live courses for students are provided by our university.
  3. A single quiz was moved from the template course to actual courses with "Copy to" feature.
  4. In the actual courses after copying, the quiz shows up under quizzes, but not under the assignments tab in the appropriate assignment group.

If I edit one of these "missing" quizzes from the quiz page and change none of the settings and just hit save, then the missing assignments show up in the assignments tab under the appropriate assignment group. 

 

0 Kudos