TangierClarke
Community Member

Student submitted videos work in app, but not web browser.

Hello everyone. I've been trying to figure out why I cannot play student-submitted videos which are formatted in a Canvas-supported video format in a web browser such as Chrome or Safari, but they play fine in my Canvas Teacher app on my iPhone.

I started a similar inquiry here (https://community.canvaslms.com/t5/Canvas-Question-Forum/Can-I-play-submitted-video-files-directly-i...

Supposedly I need to have a "Click to view" option, but I don't have that anywhere in the browser. I certainly don't have that on my iPhone and I can play it anyway. ThoughI tend not to do any grading from my iPhone.

Labels (2)
0 Kudos
2 Replies
greydon
Instructure
Instructure

Hello @TangierClarke 

It is strange that it works within the app but not on a browser. Are you using the browser on a computer or tablet or  phone? It is likely your internet browser and we recommend clearing the cache and cookies or trying another browser.

In Chrome
On your computer, open Chrome.
At the top right, click the three dots
Click settings
On the left, choose Privacy and Security
Then, clear browsing data
At the top, choose a time range. To delete everything, select All time. I suggest at least 4 weeks
Next to "Cookies and other site data" and "Cached images and files," check the boxes.
Click Clear data.

if that doesn't work, can you try a different browser or device? Presuming these are assignment submissions and not a discussion - you should be able  to view any of these videos within the speedgrader.  

Thank you for the response. I've tried both Safari (my primary browser) and Chrome and I get the same results. I emptied caches before typing my original email. There is no preview in Canvas.  Take a look at what I see with a test student submission I juste created using a student's motion graphics character video. Chrome is first, then Safari, then iOS. iOS is thinly one that gives me a preview and I can play it in place.

I also tried your instructions and nothing changed. I followed similar instructions for Safari. I have content blockers disabled, and I have my Safari preferences to allow Auto play of media at this site domain.

 

 

0 Kudos