barbarao
New Member

Using MyMedia/Kaltura in Group Discussions?

Jump to solution

We use Kaltura to provide video service for our MyMedia functions. Students and faculty love it and it has greatly helped with accessibility requirements, etc. However, just found out that when assigned a GROUP discussion, students don't have access to their MyMedia. We have a Kaltura icon on the text box "reply" editor, but when students wanted to embed their video from their MyMedia to the group discussion, "Access Denied" appeared. Works fine for regular discussion posts.  Has anyone else experienced this? Thoughts?

0 Kudos
1 Solution
brett_g_dalton
New Member

 @barbarao ‌   The issue in Groups is common to most LTI's.  Canvas groups are not really a course so don't pass a course context to the LTI tool and a lot just fail like Kaltrua does.  If they do a standard embed and you allow them to embed external to the LMS as well then this should work.

View solution in original post

6 Replies
stuart_ryan
Coach Emeritus

Hi  @barbarao ,

I wanted to check in as I noted that your question seems to have the community a little stumped. I am sure by now you will have found a possible solution or workaround through some of your own additional sleuthing? If not, do you still need assistance with this (please let us know, we are always happy to help)!


If you did find a solution that solved this, it would be great to hear from you how you did (as this will help anyone else that finds your question in future).
 
Cheers,
Stuart

Robbie_Grant
Coach Emeritus

 @barbarao ,

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.

 

Robbie

0 Kudos
jmwatson1
Community Participant

HeyBarbara,

I also have this question. Were you able to find a solution?

0 Kudos
brett_g_dalton
New Member

 @barbarao ‌   The issue in Groups is common to most LTI's.  Canvas groups are not really a course so don't pass a course context to the LTI tool and a lot just fail like Kaltrua does.  If they do a standard embed and you allow them to embed external to the LMS as well then this should work.

Hi @brett_g_dalton - 

We are experiencing this issue as well. Just to clarify your response; by "do a standard embed", do you mean have them embed the iframe HTML into the discussion response? Or is there a setting in the Kaltura backend that we should change?  

Tags (1)
0 Kudos

We are also experiencing this issue. Are there any better workarounds than asking students to pull the embed code and put it in the discussion board? That seems a little clunky for such a major tool within the LMS.

0 Kudos