Showing results for 
Search instead for 
Did you mean: 

Course Analysis Tool

Champlain College developed a Course Analysis Tool to be used in our QA process for online courses. The tool is built entirely on top of Google Spreadsheets and pulls data directly from Canvas via the API. We will present the features of the tool and share it with participants.

Presenter: Josh Blumberg​ - Champlain College

  Location Map & Room: SILVERADO 1

  Login to "Add a comment" below!


24 Replies

Replying directly so you have my email.

Can you try this against a different course and see if you get the same

error. We are still using the tool quite a bit here in house and no-one

mentioned an issue to me so I am curious what is breaking it.

I haven't updated the code in quite a bit but it does seem to keep chugging

along. The person who wrote the majority of the project moved on a few

years ago and I rarely find the time for coding in my role.



Josh Blumberg

Director of Academic Technology

The Center for Learning and Technology

Champlain College

802-383-6678 <>

On Thu, Sep 21, 2017 at 3:18 PM, <

Surveyor II

Anyone know if this continues to work?

Mine seemed to stop working so I am wondering did it start to fail.


My guess is that the API key you created expired.  You may need to generate a new API key in Canvas and add it back to the spreadsheet.

I know a bunch of staff here at Champlain College who continue to use it daily, so I would hear if it stops working.

We haven't updated the code in a long time, but Instructure also hasn't changed the Canvas API, so the tool continues to be quite reliable.

Surveyor II


Thank you so much!

I will work on that. 

Community Member

Hi Josh, this seems like a great tool and I'm looking forward to using it.  I tried to use it but keep getting a "Syntax Error: Unexpected Token".  I created first a token with an expiration date and typed the information into the Credentials sheet on my own copy in my googledocs account.  When I received this error, I tried a token with no expiration date so I could leave everything but the B2 field in the Credentials sheet blank.

I appears that I do have the correct institutional link because I tried to change that and got a different error.  No sure what I am doing wrong?  The token is listed in my account settings as being there and active.