Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Champion

Canvas Google Apps LTI authorization failures

Jump to solution
  • UPDATE Jan 18, 2018  —Still broken. No word on a fix....
  • UPDATE Aug 8, 2017  —Canvas recognizes this is a bug and is working on a fix (Cases #01843701, #01865357, #02000557). Not sure how or where to get updates on their progress.
  • UPDATE Aug 4, 2017  —Still broken. Still no error message suggesting the user switch browsers or login to Chrome with another account. Still many confused users getting frustrated because Canvas doesn't work Smiley Sad.
  • UPDATE Apr 24, 2017 —Still broken. Not answered. Don't let the "Assumed Answered" label fool you.
  • UPDATE Apr 20, 2017 —Still broken. No movement to fix on Instructure's part. They say it's "working as designed." If so, their design that forces students to jump through more hoops (see comments below) to access course content is a bad one. The goal should be to minimize navigation efforts and maximize access to content. The Canvas Google Apps LTI fails in this criteria.

ORIGINAL ISSUE, AS IT STILL STANDS — The Canvas Google Apps LTI authorization is failing on me in Chrome in one course (not others), and observed with faculty. Anyone else? Workarounds?The chat with Instructure support helped determine that it worked in Firefox but not Chrome. They suspected it may have something to do with being logged into multiple accounts. His boss suggested that the Google Apps LTI might need to be re-setup (by our Admin). 

Here's a screencast of the issue: Canvas Google LTI failures - YouTube 

More troubleshooting:

  1. I cleared all Instructure and Canvas cookies,
  2. then logged out of all Google accounts in Chrome,
  3. then shut down and restarted Chrome.
  4. Then opened afflicted Canvas course (
  5. Still saw no Google content and was asked to Authorize. Authorization fails.


  • works in Incognito mode in Chrome.
  • works in other Canvas courses in Chrome.
  • works in Firefox.

Final bit of troubleshooting:

  • it seems to definitely be the Canvas tool's issue. 
  • a manual Google Doc iFrame embed works fine in Chrome, in that course.
3 Solutions

Accepted Solutions
Community Champion

 @johnmartin ‌ I haven't used Google Apps LTI, and would be interested to know more about what you are experiencing.

Please post back with any info you learn.

View solution in original post

Thanks  @jomontuori  . Yes, this has always worked for me. The problem is that we'd have to explain this to 60,000 users who are used to not having a problem using multiple Google accounts — they don't have to do this with other Google API integrations; just Canvas. This special exception for Canvas, imho, should be removed as a matter of removing barriers for learning. 

In the meantime, the other workaround — that doesn't require users to change ingrained behavior to access course content — is to use iFrame embedding.

I surely hope Instructure can recognize that adding this barrier for student-access to content is a step backwards that should be done correctly.



View solution in original post

New Member

Hey Everyone - I have the solution!  At least it worked for us...


This does involve going into Google Admin and making a change to the Sharing settings for the Drive and Docs app settings.


1 - Go here

2 - Scroll to Option 2, then number 2 "Go to Apps > Google Workspace > Drive and Docs"

3. Make sure you are in the Sharing Settings, then choose the proper OU that you would like to make the change for.

4. The setting that needs to be on is: "When sharing outside of "your institution name" is allowed, users in "current OU" can make files and published web content visible to anyone with the link.

View solution in original post

0 Kudos
113 Replies
Community Champion

 @johnmartin ‌ I haven't used Google Apps LTI, and would be interested to know more about what you are experiencing.

Please post back with any info you learn.

Community Champion

Google Apps LTI is still broken for me and some of our faculty.

More trouble shooting.

  1. Campus admin "reset" the LTI as suggested by Canvas help.

Authorization Failed

  1. Removed all instructure cookies.
  2. Removed all Canvas cookies.
  3. Restarted Chrome.
  4. Reopened Canvas course.
  5. Reauthorized as directed.

Authorization Failed

  1. Removed all Chrome extensions
  2. Removed all Canvas & Instructure cookies
  3. Restarted Chrome & Canvas
  4. Reauthorized.

Authorization Failed

  1. Re-registered Google Drive in Account settings.
  2. Re-Integrated "User-Generated Google Apps Integration LTI" in Account settings.
    • 1. Click on "Account" in the left-hand navigation
      2. Click on "Settings"
      3. Scroll down to "Approved Integrations"
      4. Find the integration titled "Google Drive LTI IAD-Prod"
      5. Click the trashcan to the right of that integration
      6. Try again to authorize your account to Google
  3. Reauthorized.

Authorization Failed

  • Google Apps LTI still works in Firefox and in Chrome Incognito mode
  • Google docs still embed nicely if manually iframed

Anyone from Canvas looking into this?

Community Champion

Here's a screencast of the issue.

Canvas Google LTI failures - YouTube 

 @johnmartin , your screencast didn't come through; could you re-post?

Ugh, I dislike that the community forum doesn't support embeds... 😞

(Link added to post)

Community Contributor

 @johnmartin , my co-Canvas Admin and I have experimented with the Google Apps LTI in our Canvas instance, a K-12 district, with our own Google domain. 

My district Google account authorization in Canvas worked at first. Now it doesn't. My co-Admin's is still working, as is that of another colleague, a teacher without Admin access.

One other factor that may be relevant. My co-Admin and I both added the Google LTI, independently, and at different moments. We wondered if that somehow created my problem.  

Community Champion

We have found that we have to login to the google account that is linked to our Canvas account first and then use the LTI.   If we do that it works,  if we don't we get the authorize.  Most of our users use Chrome.  Since you have to login first, it works really well on Chromebooks because you have to login to the chromebook and for us that is the account that is tied to Canvas.  

Community Champion

Canvas replied: 

The Google Drive Registered Service is not related to the Google LTI other than being you log into your Google Account with both. So the account signed up for the registered service should not affect the Google LTI log in. 

You stated that when adding the two accounts in Chrome, you were still unable to authorize. I have been testing this and was unable to replicate the issue. When I add the two accounts to my Google account on the LTI will authenticate. I have created a screencast of my testing that I hope helps:

Don't hesitate to let me know if you are still coming across this issue, I'd be more than happy to give you a call if needed so we can get this going for you. Please let us know if you have any additional questions; happy to help

When we are done responding to a case we put it in pending waiting for a response. Were you able to look at my screencast, to see my findings? Please let us know if you have any additional questions; happy to help

I responded: 

Alas, my experience is still different than yours. I've created another screencast doing what you did in your screencast. Sorry for the poor audio quality.
Thanks for digging into this further!
Community Contributor

Ah. Problem resolved for me. Hope this helps you too,  @johnmartin ! 

I was logged into Google Drive with my district Google account (the one I was also authorizing Canvas to access). However, I was logged into my Chrome browser using my personal Google account. Apparently, this was causing a conflict. Frankly, I don't even remember logging into Chrome, but it's a setting that remains even when you restart your device. 

So once I logged into Chrome with the same Google account in Chrome, Drive, and the Google App LTI authorization, the Google Apps LTI worked fine. 

218057_Screen Shot 2017-02-22 at 10.49.54 AM.png