cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
amy_plant
Community Member

Images in Email notifications

Jump to solution

When I send invitations to join a course, the button to get started and the canvas logo are not appearing. I checked permissions on the images folder and its contents, and it is set to 775. When I view the email source code and copy and past the URL into a browser, I can see the images. 

In addition, I would like to know where I can set the variable 'custom_logo' to display the company log and not the canvas logo, which I think should be in admin settings, but I can't find where.

1 Solution

Accepted Solutions

I did eventually figure it out. 

1) The site where the images are stored, needs to be secured with an SSL (https)

2) To display the company logo requires getting access to the debase, and setting account.settings[:email_logo] to the correct URL of the custom company logo.

View solution in original post

6 Replies
kmeeusen
Community Coach
Community Coach

Hi  @amy_plant  Welcome

I do at least have an answer one one of your questions...............

That will help you set a theme, and brand it with your school's own logo.

I hope this helps,

KLM

Thanks, I have done that quite successfully Smiley Wink

Robbie_Grant
Community Coach
Community Coach

 @amy_plant ,

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.

 

Robbie

I did eventually figure it out. 

1) The site where the images are stored, needs to be secured with an SSL (https)

2) To display the company logo requires getting access to the debase, and setting account.settings[:email_logo] to the correct URL of the custom company logo.

View solution in original post

nicolopez77
Community Participant

Does anybody know if this is still valid in 2021?

Should i add the ":email_logo: https://abc.com/logo.png" to the Site Admin record, or to the account record in accounts.settings?

 

Thanks!

ChrisDao
Community Participant

@nicolopez77 ,

I haven't tested this but in Canvas Official document: https://github.com/instructure/canvas-lms/wiki/Settings-%28customization%29

They have provided the custom setting like: 

Setting.set('codecogs.equation_image_link', "<your custom url>")

For your case, it might be: Setting.set('email_logo', '<your url>')

And for this type of Commands, it's used in your Rails console.

Just try, I haven't known if this is right or not, but at least it's worth trying.