barsmith
Community Member

LaTeX no longer renders as an equation

Jump to solution

For the last couple of years, LaTeX code typed between \( and \) would render as an equation once a Canvas page was saved. This was not working for me today. Typing, say, \( k^2 \) just produced "\(" rather than the desired k with an exponent 2 on it. I see that I can now enter LaTeX code directly in the equation editor without having to click to switch to "Advanced." But the great thing about the \( and \) was that I could just type up a long page on Canvas with lots of equations and not have to spend a bunch of time repeatedly clicking into the equation editor and then clicking save.

Labels (1)
0 Kudos
1 Solution
James
Community Champion

@barsmith 

I just tried entering \( k^2 \) and it worked fine inside Chrome on Windows. Perhaps there was a network issue earlier in the day when you tried this and it couldn't load MathJax? It may have also been that there was a problem earlier in the day and Canvas fixed it.

To double check, you are trying this in a browser? The last I checked, direct entry of LaTeX doesn't work on the mobile app unless you have at least one equation on the page that is entered the normal way.

Another thing to check is to look at the HTML source for the page and make sure there aren't any stray characters that got introduced.

If you're still having the problem, can you try it on a new page? There's a possibility that there is a stray \( or \) somewhere else on the page that is messing the parsing up.

View solution in original post

2 Replies
James
Community Champion

@barsmith 

I just tried entering \( k^2 \) and it worked fine inside Chrome on Windows. Perhaps there was a network issue earlier in the day when you tried this and it couldn't load MathJax? It may have also been that there was a problem earlier in the day and Canvas fixed it.

To double check, you are trying this in a browser? The last I checked, direct entry of LaTeX doesn't work on the mobile app unless you have at least one equation on the page that is entered the normal way.

Another thing to check is to look at the HTML source for the page and make sure there aren't any stray characters that got introduced.

If you're still having the problem, can you try it on a new page? There's a possibility that there is a stray \( or \) somewhere else on the page that is messing the parsing up.

Thanks. It is working for me now. I don't know why it didn't before (I am using a browser, not a mobile app).