cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JohnBlazier
Community Member

Making announcements visible

Jump to solution

Can you please try again to answer this question, i.e. not just link to that unhelpful "How do I manage Course Navigation links?" page? Clearly people keep asking this question. How do you make the crossed out eyeball go away? I don't want to know how to re-order anything in the course navigation screen...that's not the question. No one asked that question.

 

0 Kudos
3 Solutions

Accepted Solutions
James
Community Champion

@JohnBlazier 

There are two things that both need to happen for announcements to be visible to students and get rid of that crossed-out eyeball.

  1. Announcements need to be enabled in the course navigation menu.
  2. You need to post an announcement.

If you have done both of these items and it is not working, then could you please provide additional information?

Particularly helpful will be the the tooltip that shows up when you hover over the Announcements item?

If the Announcements navigation menu is enabled but there are no announcements, then the tooltip will say "No content. Not visible to students."

If the Announcement navigation menu is not enabled (regardless of whether there are announcements or not), then the tooltip will say "Disabled. Not visible to students."

 

View solution in original post

bowmanr
Community Champion

@JohnBlazier -

In copying what I have below, it may be the following comment at the very bottom that is the answer to your question(I hope):

"Any Course Navigation link that is hidden from students displays the Visibility icon [1]. A link may be hidden to students because the feature area has no content [2] or because the link is disabled [3]."

Number 2 is the answer - the visibility icon(eyeball) will show if there is no content for the navigation link - in this case no announcement posted yet

The other question you responded to had the answer in the response by @chofer 

The answer is down near the bottom of the page in the link.  You have to move the announcements from the unviewed list to the displayed list of navigation links - and the most important part - click on save which is at the bottom of the navigation settings page.  The navigation link needs to be enabled which is what the document referenced tells you how to do.  you can also drag and drop the navigation links to whatever order you want to see them displayed.

 

here is the post again: https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-manage-Course-Navigation-links/ta-p/102...

here is a screen shot of the relevant part (down near the bottom) - if this does not answer the question you want, then reply with more detail and screen shots to help us out.  

Hide Navigation Links

bowmanr_4-1622485161162.png

 

To hide a navigation link, click the link Options icon [1] and select the Disable option [2].

You can also drag and drop the link to the hidden section at the bottom of the page.

Enable Navigation Links

bowmanr_5-1622485161179.png

 

To enable a link in the hidden section [1], click the Options icon [2] and click the Enable button [3].

You can also drag and drop the link above the hidden section.

Save Navigation

bowmanr_6-1622485161181.png

 

Click the Save button.

View Course Navigation Links

bowmanr_7-1622485161187.png

 

View the Course Navigation Menu. Navigation links will display in the same order that you have designated in Course Settings.

Any Course Navigation link that is hidden from students displays the Visibility icon [1]. A link may be hidden to students because the feature area has no content [2] or because the link is disabled [3].

Note: If you have disabled a Course Navigation link to an external tool, that link will not display in Course Navigation and is hidden to all course users, including instructors.

 

 

 

View solution in original post

JohnBlazier
Community Member

The solution was hitting "Save". Apparently posting an announcement was not enough, I had to go into settings and "Save" despite not having made any changes on the Course Navigation page.

View solution in original post

5 Replies
James
Community Champion

@JohnBlazier 

There are two things that both need to happen for announcements to be visible to students and get rid of that crossed-out eyeball.

  1. Announcements need to be enabled in the course navigation menu.
  2. You need to post an announcement.

If you have done both of these items and it is not working, then could you please provide additional information?

Particularly helpful will be the the tooltip that shows up when you hover over the Announcements item?

If the Announcements navigation menu is enabled but there are no announcements, then the tooltip will say "No content. Not visible to students."

If the Announcement navigation menu is not enabled (regardless of whether there are announcements or not), then the tooltip will say "Disabled. Not visible to students."

 

View solution in original post

bowmanr
Community Champion

@JohnBlazier -

In copying what I have below, it may be the following comment at the very bottom that is the answer to your question(I hope):

"Any Course Navigation link that is hidden from students displays the Visibility icon [1]. A link may be hidden to students because the feature area has no content [2] or because the link is disabled [3]."

Number 2 is the answer - the visibility icon(eyeball) will show if there is no content for the navigation link - in this case no announcement posted yet

The other question you responded to had the answer in the response by @chofer 

The answer is down near the bottom of the page in the link.  You have to move the announcements from the unviewed list to the displayed list of navigation links - and the most important part - click on save which is at the bottom of the navigation settings page.  The navigation link needs to be enabled which is what the document referenced tells you how to do.  you can also drag and drop the navigation links to whatever order you want to see them displayed.

 

here is the post again: https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-manage-Course-Navigation-links/ta-p/102...

here is a screen shot of the relevant part (down near the bottom) - if this does not answer the question you want, then reply with more detail and screen shots to help us out.  

Hide Navigation Links

bowmanr_4-1622485161162.png

 

To hide a navigation link, click the link Options icon [1] and select the Disable option [2].

You can also drag and drop the link to the hidden section at the bottom of the page.

Enable Navigation Links

bowmanr_5-1622485161179.png

 

To enable a link in the hidden section [1], click the Options icon [2] and click the Enable button [3].

You can also drag and drop the link above the hidden section.

Save Navigation

bowmanr_6-1622485161181.png

 

Click the Save button.

View Course Navigation Links

bowmanr_7-1622485161187.png

 

View the Course Navigation Menu. Navigation links will display in the same order that you have designated in Course Settings.

Any Course Navigation link that is hidden from students displays the Visibility icon [1]. A link may be hidden to students because the feature area has no content [2] or because the link is disabled [3].

Note: If you have disabled a Course Navigation link to an external tool, that link will not display in Course Navigation and is hidden to all course users, including instructors.

 

 

 

View solution in original post

JohnBlazier
Community Member

The solution was hitting "Save". Apparently posting an announcement was not enough, I had to go into settings and "Save" despite not having made any changes on the Course Navigation page.

View solution in original post

bowmanr
Community Champion

@JohnBlazier 

That is interesting that you had to hit save even though no changes were made.  

Thanks for the response - that information will probably help someone else.

amandaru
Community Member

I've done all these things - moved "announcements" into the course navigation on the settings tab and clicked "save" as well as posted an announcement. But it still says not visible. I've refreshed, re-saved, moved announcements from disabled back to visible, saved again....