Quickstart server says "Invalid Authenticity token" - clean DB and browser does not help

Jump to solution
Community Member

Recently set up a local Canvas server according to the Quickstart guide (very nice guide, worked first time). All was well for a day. Could log in, create modules, developer keys etc etc.

Then, all login attempts started failing with a message "Invalid Authenticity token" at the top of the window.

Clearing the browser (cookies, local storage, everything) did not help. Trying a browser from a completely different machine did not help either.

Clearing out the database and starting with a new user (different email) also failed to remove the problem:

   bundle exec rails db:initial_setup

The server error log says:

Processing by Login::CanvasController#create as HTML
Parameters: {"utf8"=>"â", "authenticity_token"=>"", "redirect_to_ssl"=>"1", "pseudonym_session"=>{"unique_id"=>"dan@dyynamo.com", "password"=>"[FILTERED]", "remember_me"=>"0"}}
[AUTH] Authlogic Validation Error: You did not provide any details for authentication.
[AUTH] Authlogic Failed Find

.....and later ...

SQL AuthenticationProvider Load (0.9ms) SELECT "authentication_providers".* FROM "authentication_providers" WHERE "authentication_providers"."account_id" = 2 AND "authentication_providers"."auth_type" = 'canvas' AND (workflow_state <> 'deleted') ORDER BY "authentication_providers"."position" ASC LIMIT 1 [development:1 master]
Can't verify CSRF token authenticity.

Any help gratefully received!


Labels (1)
1 Solution
Community Member

Hello ! Did you manage to fix this issue by any chance ? I have the same problem in my Bitnami setup, but for LTI Keys.... I've tried everything in the dynamic_settings.yml file, and other settings, but I'm not sure what I'm doing wrong.



View solution in original post