Student Discussion Posts not Showing in Speedgrader

Jump to solution
Community Contributor

I have a professor that has assigned a graded discussion, however when trying to grade it through Speedgrader the post and replies do not appear.  The only thing that appears on the Speedgrader screen is:


He can select "view the full discussion" and sort by student entries.

Is there an issue with Speedgrader or a setting that he has selected?

3 Solutions
Community Contributor

This makes sense. He actually created a group set in the class but did not

place anyone in there since he didn't know how it worked. He has since

taken the group set out.

Thank you.

View solution in original post

Community Participant

The workaround below resolved our issue:

  1. In the Settings of the Discussion, uncheck the Graded option.
  2. Save the change.
  3. Go back into the Settings and check the Graded option.
  4. Save the change.

View solution in original post

Community Novice

Timothy Danner's workaround (edit discussion, marking ungraded, then changing to graded) worked for me.  I had inadvertently marked it as a group discussion to start, then when I went to Speedgrader it showed me none of the students' discussion posts (since I had set up no groups, perhaps?). 

But when I went to edit and noticed my grouping selection, I was unable to uncheck groups because students had already submitted into the discussion.  By marking it as ungraded, I was able to uncheck the groups.  Then when I edited again and marked as graded, all the students' submissions re-appeared for me in Speedgrader.

Which is awesome.

View solution in original post