Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DavidM-Griffith
Community Member

Successful QTI import but zero questions appear in Item Bank

Jump to solution

I am comfortable with the process of exporting and importing QTI 2.1 and then importing into Canvas item banks, but have a set of files that successfully import but zero questions appear after the import.

The folder and xml contents of the QTI zip look like what I'd expect. Here's a link to one of the QTI files.

Has anyone else encountered and/or solved something like this?

Labels (1)
0 Kudos
2 Solutions

Accepted Solutions
ColtonSwapp
Instructure
Instructure

Hello @DavidM-Griffith 

I was able to download the QTI file you supplied. When I imported them into an Item bank, it seems that it brought over the name of the bank called EOT Exam Pool 1. but none of the questions came over with it. 

I also tried to do a regular QTI zip file import and it did not bring the questions over with it at all. 

If I were to guess, it might be an issue with the file or the content setup within the file when it was exported. Was this zip file supplied by a publisher? They might have specific instructions on how to export the ZIP file for use in Canvas. 

Hopefully this helps! 

-Colton

View solution in original post

DavidM-Griffith
Community Member

Thanks Colton, that confirms it's not our instance of Canvas causing the issue.  It's just the QTI files from a couple of particular courses that are problematic.  I can successfully export other QTI pools from the same system and import them as Item Banks using the same processes.

View solution in original post

0 Kudos
2 Replies
ColtonSwapp
Instructure
Instructure

Hello @DavidM-Griffith 

I was able to download the QTI file you supplied. When I imported them into an Item bank, it seems that it brought over the name of the bank called EOT Exam Pool 1. but none of the questions came over with it. 

I also tried to do a regular QTI zip file import and it did not bring the questions over with it at all. 

If I were to guess, it might be an issue with the file or the content setup within the file when it was exported. Was this zip file supplied by a publisher? They might have specific instructions on how to export the ZIP file for use in Canvas. 

Hopefully this helps! 

-Colton

DavidM-Griffith
Community Member

Thanks Colton, that confirms it's not our instance of Canvas causing the issue.  It's just the QTI files from a couple of particular courses that are problematic.  I can successfully export other QTI pools from the same system and import them as Item Banks using the same processes.

0 Kudos