Can no longer edit Canvas courses

Jump to solution
Community Explorer

Last week I suddenly found I could not edit my Canvas courses.  As it was my organisation's site, I contacted canvasadmin, who did not know why.  I also checked and found that the same thing had happened to my Free for Teacher account, so I figured it was probably something to do with my computer, and probably a win11 update.  So I rolled back to a previous restore point, and all was fine on both accounts.  Problem solved.... or so I thought.

Today the same problem has arisen.  (I will describe below...).  I tried restore, but for some reason my computer refuses to roll back to the only available restore point.  So I am now faced with a growing number of courses I can't update, and no apparent solution.  I contacted help, and they couldn't be bothered to help, so I'm hoping someone here has a solution.

Description of problem

First of all, using the three dots at the end of the module heading does nothing, ie no dropdown menu.  Secondly, clicking the three dots at the end of each item line within the module simply shoots you up to the top of the screen, where 'add module' is highlighted.  I still think its likely to be a win11 update problem, but I don't know, and I haven't a clue how to cure it, short of resetting the computer.

Any suggestions?

Labels (1)
1 Solution
Community Coach
Community Coach

Hey there, @silvamayflower@TrishaMeyer1, and @nwilson7 ...

I wanted to point you all to this document which I was made aware of this morning.  It looks like this will be fixed in your "production" environment (the Canvas environment you normally sign in to on a regular basis) on October 12, 2022.  Here is the document:

3 Dots / "Kabob" on Modules and Assignments index ... - Instructure Community (

Hope this will help!

View solution in original post