cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
m_garcia1
Community Participant

Setting the landing/frontpage

Jump to solution

Hi,

I am just starting with Canvas so sorry if what I ask is very basic, but I have followed instructions in the manual, not working and it is driving me mad:

I want that the frontpage/landing page of my course is a page in which I will create a index/visual navigation index to all the modules that comprise the course in order to avoid the (in)famous 'scroll of death'. I have set up the homepage in question but, when I go to the course, both as an instructor and using the student view, I am still re-directed to the 'Home' and see the 'Getting started wtih the course' module, rather than the page.

I tried moving 'Pages' over the 'Home' tab but it doesn't make any difference. I have tried to disable the 'Home' tab but I don't think that you can.

Any ideas of why I cannot see the landing page displayed in the central section of the course?
Many thanks.

Mari Cruz

326896_Capture1.PNG

326897_Capture2.PNG

1 Solution

Accepted Solutions
Robbie_Grant
Community Coach
Community Coach

 @m_garcia1 ,

If you have the page created in the Pages tool, thy this:

1. Go to Pages.

2.  Locate the page that you would like to set as your home page and click the Settings icon (three vertical dots).

3. From the Settings menu, click the Use as Front Page option.

4.  Click the Home button on your left side Navigation menu.

5. Click the Choose Home Page button on the right side bar.

6.  Select the radio button next to Pages Front Page (your page should be listed in italics).

7.  Click Save.

Hope this Helps!!!


Robbie

View solution in original post

4 Replies
Robbie_Grant
Community Coach
Community Coach

 @m_garcia1 ,

If you have the page created in the Pages tool, thy this:

1. Go to Pages.

2.  Locate the page that you would like to set as your home page and click the Settings icon (three vertical dots).

3. From the Settings menu, click the Use as Front Page option.

4.  Click the Home button on your left side Navigation menu.

5. Click the Choose Home Page button on the right side bar.

6.  Select the radio button next to Pages Front Page (your page should be listed in italics).

7.  Click Save.

Hope this Helps!!!


Robbie

View solution in original post

m_garcia1
Community Participant

Many thanks for your help, @Robbie Grant Admin , I think the problem is in this three steps:

Robbie Grant Admin 

4.  Click the Home button on your left side Navigation menu.

5. Click the Choose Home Page button on the right side bar.

6.  Select the radio button next to Pages Front Page (your page should be listed in italics).

4. I click on the Home button on my left. I cannot click on from 'Settings' so I assume that we have come back to the main screen:

326910_Capture.PNG

5. Click the Choose Home Page button on the right side bar. 

I cannot find this button anywhere near the 'Home' button either in that screen or in the 'Settings' screen:

326911_Capture2.PNG

Am I missing something or the option may have been disabled at a site level by the administrator?

Many thanks..

Mari Cruz

Hi  @m_garcia1  

I sense that you are a visual learner, so I will include those later, but the biggest mistake I see in trying to follow  @Robbie_Grant  ' instructions is that you went to Settings. There is no need to go to Settings at all. And, for the record, you most certainly can go to the Home page from within the Settings page.

I will use Robbie's steps below, but also add screenshots.

1. Go to Pages. Click "View all Pages"

327051_pastedImage_4.png

2.  Locate the page that you would like to set as your home page and click the Settings icon (three vertical dots).

327052_pastedImage_6.png

327054_pastedImage_9.png

3. From the Settings menu, click the Use as Front Page option.

That page will now be listed as your "Front Page"327055_pastedImage_10.png

327056_pastedImage_12.png

4.  Click the Home button on your left side Navigation menu.

327057_pastedImage_14.png

5. Click the Choose Home Page button on the right side bar.

327058_pastedImage_16.png

6.  Select the radio button next to Pages Front Page (your page should be listed in italics).

327059_pastedImage_18.png

7.  Click Save

327060_pastedImage_20.png

I hope this is helpful,

Kelley

m_garcia1
Community Participant

Mistery solved! Thank you very much. I got it now ans worked!