cancel
Showing results for 
Search instead for 
Did you mean: 
mfreedman3
Community Participant

Disappearing Graphics

Jump to solution

I have jpg images which display just fine, then for no apparent reason they disappear, only showing the file name.  Is this a bug? Am I doing something wrong?

279413_pastedImage_1.png

145 Replies
Bobby2
Community Coach
Community Coach

 @holtond1 I'm passing this little gem on. Thank you!

wendy_fletcher
Community Participant

Helpful if the images are actually missing or the file path is wrong, but there is a repeated issue with images that are in correct spot not showing , then reappearing later with no changes made. I've encouraged some of my students to refresh multiple times eg using F5 and this sometimes gets the missing images. 

Yes this is exactly what I am finding, images are correct,in correct spots, linked correctly,  still vanish sometimes then reappear later. ..

s_carter
Community Participant

Yes, we are having exactly the same issue. It does not seem to be a cache/refresh issue as on one page the images will (sometimes) not display properly, but on other pages the images will display perfectly - without refreshing. This is very frustrating.

And different people in the same course see images when others can't. 

Amanda_L_Albrig
Community Participant

I ran into this in December 2017 and was told the issue was fixed. I'm wondering if something was done in the background again to break it.

----------message from 2017-----------------

Subject: Canvas Support: Images not appearing in Quizzes - Case #02668867

Hello:

Thank you for contacting Canvas Support. I understand that file links within the Final Quiz are showing as broken when students take the Quiz. In looking into this it appears that this may have been in relation to a previous bug that has since been fixed. I can see that when I try resetting the links by embedding the image from the course files at this time it displays the image correctly. Please follow the steps in THIS guide to get those image links reset and please let us know if users are still reporting trouble with this so we can take a closer look if needed.

Thank you! Smiley Happy

c_murphy
Community Participant

Just adding in our voice to this - we have had this issue as well and it is a tremendous disadvantage when planning online and blended courses which rely on images which are informational rather than decorative. As a workaround we've offered a link to the graphic as well as embedding it, but this is not ideal. Something is definitely going on here.

brendaa
Community Contributor

We are experiencing the same issue.  Clearing the cache does work, but this is not an acceptable solution.  We are using lots of images for our online and blended courses, but it is disappointing to realize that students may end up seeing a broken image icon instead.  All of our images are in the Files sections of their respective courses.  The "disappearing" images are random.  One staff member may not see an image, while everyone else does.  This is happening across Chrome and Safari web browsers for us.  I'm not sure about Firefox since that is not used as often.  Our students also report that Chrome and Safari are the most used browsers so we need images to consistently work on these browsers.  I'll try to call Support the next time this happens to me and report it and request they screenshare and view the problem.

lewisale
Community Champion

I have also had this problem routinely.  I contacted Canvas Chat, and they recommended clearing the cache.  This fix only worked for a few days.  I noticed this problem in Chrome; I was able to see the images in Firefox. I created a quiz that has images, and I am now concerned these quiz items may not appear for all students.  I hope there is something Canvas can do to assist with a permanent fix.  Maybe in the future Canvas may consider creating their own browser.

b_w_reid
Community Participant

I raised this issue with Canvas and they recommended we white-list a list of Canvas services. We haven't implemented this yet, but are investigating this issue further before we make any changes. I use Chrome, and I have noticed that the images appear fine initially, but then if you leave the window open, navigate away from the images page, and open a different course, and then return to the same course over an hour later, this is when they tend to drop off.

The images seem to re-appear if you to a cache refresh using 'ctrl' + 'f5' in the browser.