Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Member

Files/documents preview won't load, is there something I can do?

All of a sudden files and documents submitted by my professors, in the modules, will not load their preview. The blue wheel just spins and spins. I have to download every document to look at it. Did I disable something, maybe? 

18 Replies
Community Champion

I'm surprised I didn't see this thread before now.

If you're using Chrome, then the working theory is that there is a browser extension that is causing the problem. Adblocker Plus, Ghostery, and Honey are all known to cause problems. There are some others that I cannot remember right now. It seems to mostly be apps that can "read and change all your data on the websites you visit."

One way to test this is to open up an incognito window in Chrome (Shift+Ctrl+N). Then log into Canvas and try to view the content. If it works now, then it is most likely an extension causing a problem.

Disabling the extension isn't enough in some cases. Disabling Honey worked at first, but then the problem showed back up later in the day and my wife had to completely remove it.

Here are some links to other threads where this has been discussed. I may have missed some others.


Tags (3)

Thank you!! This fixed my problem
Community Member

So what do I do if I still can't load previews under incognito mode?


I'm on a new computer with no extensions (other than Google products and Adobe)

Community Member

Same here. I've been having this issue since May and I have been forced to download all my documents. I have tried to disable all my Chrome extensions to no avail. I have also left it loading in the background for hours, but nothing changed :/.

Community Member

I have also been having this issue for the last couple of months, and I am on the latest version of Chrome. If anyone comes across a fix for this it would be greatly appreciated.

Community Champion


When I first started describing this issue to people, I used to throw in that it was likely an extension or a cookie problem. When some many of the people having the problem came back with disabling extensions fixed it, then I stopped adding the cookie part.

Before doing other things, I would try disabling Adobe products within the browser. I have the Acrobat extension that comes with Creative Cloud and didn't like the prominence that it took or how it acted. I'm sure that others like it there, the point was that not all extensions are disabled in incognito mode and sometimes it's the things we don't expect.

The second thing is that I would try with Firefox and see if it works there. If so, then we know it's something related to Chrome or what you're using there and not just an issue with the particular file you're trying to load. Well, at least mostly we know that. It could be a network glitch at the time you were trying to use Chrome that resolved itself by the time you're trying to use Firefox.

When I first had problems with things not working in Canvas, it was a third-party cookie issue. I normally have my security set to a higher level of privacy when possible, but it can cause problems with things not loading properly. Mine was Google Apps and students were submitting things I couldn't see. Right now, in the community is there is an eyeball with a slash through it on the right of the location bar in Chrome. That means that cookies are getting blocked. Six of them, in fact. If I click there, I can eventually get to a list of things that are blocked (it's on the community site). I look through the list and if it appears to be instructure-related or something that seems legit, like, then I will allow it. I can't show any pictures to help as I've already reached my 1000 image limit with the content they copied over from the old site.

Another thing I'll do is open up the developer tools for the browser (F12) and watch the console and network tabs when I load the page to see what the problems are. If there are calls being made that are getting rejected with errors in the 400s, then that's a place to look. There is also an issue with same-site cookies. Canvas says they're fixed, but I still see too many warnings about it to believe that.

Generally, waiting a long time won't fix things, although there were a few days within the last week where load times were terribly slow for some people. That seems to have been resolved for now, but it was taking 30 seconds for some of my PDFs to load.

Community Participant

We are having exactly this problem too. Frustrating!

Community Member

We had the same issue on a quiz which required the Respondus LockDown browser. About half-way in there were many students who could not load PDF files embedded in to Text questions on a graded quiz.

Community Participant

Disabling Tampermonkey extension fixed the issue for me.