Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Viewing media in the Rich Content Editor

Viewing media in the Rich Content Editor

Viewing media in the Rich Content Editor requires a Canvas-supported browser.

If media does not play using a supported browser and was uploaded by the course instructor, verify with the instructor that the media is accessible to course users. By default, media that is recorded or uploaded using the Rich Content Editor is visible to users within the announcement, assignment, discussion, page, quiz, or syllabus. However, if the uploaded file's restriction settings were changed to unpublished or are outside of the file's visibility dates, users will not be able to view the file.

Check Browser Compatibility and Computer Requirements

Check Browser Compatibility and Computer Requirements

Media added to a course using the Rich Content Editor may not play if you are using an outdated browser or do not meet certain computer requirements. Verify browser compatibility and computer requirements using the Is My Browser up to Date? tool.

Verify File Restriction Settings with Instructor

Verify File Restriction Settings with Instructor

If media does not play using a supported browser and was uploaded by the course instructor, verify with the instructor that the media is accessible to course users.

By default, media that is recorded or uploaded by instructors using the Rich Content Editor is visible to users within the announcement, assignment, discussion, page, quiz, or syllabus. However, if the uploaded file's restriction settings were changed to unpublished or are outside of the file's visibility dates, users will not be able to play the media file.

Was this article helpful? Yes No
Featured Guides
Have a question about Canvas? Ask in the Q&A forum:
Browser/iOS Compatibility

Desktop Browsers

View full details
  • Chrome 102 and 103
  • Firefox 100 and 101
  • Edge 101 and 102
  • Respondus Lockdown Browser
  • Safari 14 and 15

Mobile Browsers

View limited support guidelines
  • Latest version of Safari (iOS) and Chrome (Android)

Mobile Apps

  • Android 8.0 or later
  • iOS 14.0 or later